<!DOCTYPE html><html><head><script crossorigin="anonymous" src="https://polyfill.io/v3/polyfill.min.js?features=NodeList.prototype.forEach%2CArray.prototype.forEach%2CSymbol.hasInstance%2Ces6%2CIntl%2ClocalStorage%2CDate.prototype.toISOString%2CDate.now%2Cdefault%2CObject.entries%2CArray.prototype.entries"></script><title>Latest Idaho news, sports, business and entertainment at 6:20 a.m. MDT</title><meta name="viewport" content="width=device-width, minimum-scale=1, initial-scale=1"/><meta http-equiv="X-UA-Compatible" content="IE=edge"/><meta charset="UTF-8"/><meta name="distribution" content="global"/><meta name="rating" content="general"/><meta name="copyright" content="Copyright (c) 2020 "/><meta property="og:locale" content="en_US"/><meta property="og:type" content="article"/><meta name="burst" content="kmtv"/><meta property="og:url" content="https://www.kmvt.com/2020/07/06/latest-idaho-news-sports-business-and-entertainment-at-620-am-mdt/"/><meta name="robots" content="index,follow,noarchive"/><meta name="googlebot" content="index"/><meta name="googlebot-news" content="index"/><meta itemProp="description" name="description" content="Latest Idaho news, sports, business and entertainment at 6:20 a.m. MDT"/><meta property="og:description" content="Latest Idaho news, sports, business and entertainment at 6:20 a.m. MDT"/><meta name="twitter:description" content="Latest Idaho news, sports, business and entertainment at 6:20 a.m. MDT"/><meta property="fb:admins" content="644426401"/><meta property="fb:app_id" content="644297505713954"/><meta property="fb:pages" content="115637561829471"/><meta property="article:publisher" content="https://www.facebook.com/KMVTNews11/"/><meta name="keywords" content="ID,2nd Right Now"/><meta name="news_keywords" content="ID,2nd Right Now"/><meta itemProp="image" property="og:image" content="https://www.kmvt.com/pf/resources/images/logo-icons/kmvt.svg?d=73"/><meta name="twitter:image" content="https://www.kmvt.com/pf/resources/images/logo-icons/kmvt.svg?d=73"/><meta property="og:site_name" content="https://www.kmvt.com"/><meta property="og:title" content="Latest Idaho news, sports, business and entertainment at 6:20 a.m. MDT"/><meta name="twitter:title" content="Latest Idaho news, sports, business and entertainment at 6:20 a.m. MDT"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content="@kmvtnews"/><meta name="twitter:creator" content="@kmvtnews"/><script type="application/ld+json" data-schema="NewsMediaOrganization">{
  "name": "KMVT",
  "url": "https://www.kmvt.com",
  "logo": {
    "@type": "ImageObject",
    "url": "https://www.kmvt.com/pf/resources/images/logo-off-site/kmvt.png?d=73"
  },
  "@type": "NewsMediaOrganization",
  "sameAs": [
    "https://www.facebook.com/KMVTNews11/",
    "https://www.instagram.com/kmvtnews/",
    "https://www.twitter.com/kmvtnews/"
  ],
  "@context": "http://schema.org"
}</script><script type="application/ld+json" data-schema="NewsArticle">{
  "name": "Latest Idaho news, sports, business and entertainment at 6:20 a.m. MDT",
  "url": "https://www.kmvt.com/2020/07/06/latest-idaho-news-sports-business-and-entertainment-at-620-am-mdt/",
  "image": "https://www.kmvt.com/pf/resources/images/logo-off-site/kmvt.png?d=73",
  "@type": "NewsArticle",
  "@context": "http://schema.org",
  "description": "Latest Idaho news, sports, business and entertainment at 6:20 a.m. MDT",
  "keywords": [
    "ID",
    "2nd Right Now"
  ],
  "headline": "Latest Idaho news, sports, business and entertainment at 6:20 a.m. MDT",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.kmvt.com/2020/07/06/latest-idaho-news-sports-business-and-entertainment-at-620-am-mdt/"
  },
  "author": {
    "@type": "Organization",
    "name": "KMVT"
  },
  "publisher": {
    "name": "KMVT",
    "url": "https://www.kmvt.com",
    "logo": {
      "@type": "ImageObject",
      "url": "https://www.kmvt.com/pf/resources/images/logo-off-site/kmvt.png?d=73"
    },
    "@type": "NewsMediaOrganization"
  },
  "datePublished": "2020-07-06T09:23:30.312Z",
  "datemodified": "2020-07-06T09:23:30.312Z"
}</script><script type="application/javascript">if(!Array.prototype.includes||!(window.Object && window.Object.assign)||!window.Promise||!window.Symbol||!window.fetch){document.write('<script type="application/javascript" src="/pf/dist/engine/polyfill.js?d=73" defer=""><\/script>')}</script><script id="fusion-engine-script" type="application/javascript" src="/pf/dist/engine/react.js?d=73" defer=""></script><script id="fusion-template-script" type="application/javascript" src="/pf/dist/template/article-default-template/default.js?d=73" defer=""></script><link id="fusion-template-styles" rel="stylesheet" type="text/css"/><link rel="stylesheet" href="https://gray-kmvt-prod.cdn.arcpublishing.com/pf/resources/dist/kmvt/css/main.css?d=73"/><link href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/5.10.2/css/all.min.css?d=73" rel="stylesheet"/><link rel="icon" type="image/x-icon" href="https://gray-kmvt-prod.cdn.arcpublishing.com/favicon.ico"/><script type="text/javascript" src="https://gray-kmvt-prod.cdn.arcpublishing.com/pf/resources/js/analytics/gtm.js?d=73"></script><script type="text/javascript" src="https://gray-kmvt-prod.cdn.arcpublishing.com/pf/resources/js/ads/arcads.js?d=73"></script><script type="text/javascript">
    var RCdataLayer = [
      {
        adTarget: "/wires",
        authors: [ ],
        canonicalUrl: "https://www.kmvt.com/2020/07/06/latest-idaho-news-sports-business-and-entertainment-at-620-am-mdt/",
        contentId: "722LXIEJOFHTDPRB4YNGYI5TLE",
        contentKewords: [ "ID","2nd Right Now"],
        contentName: "Latest Idaho news, sports, business and entertainment at 6:20 a.m. MDT",
        contentOwner: "gray",
        contentTags: [ ],
        contentType: "story",
        datePublished: "07/06/2020",
        distributorCategory: "wires",
        distributorMode: "reference_denormalized",
        distributorName: "AP Idaho",
        distributorReferenceId: "64daba07-65f0-47d1-b659-62bb27a2b2cc",
        distributorSubCategory: "ap-newspower",
        hasVideo: false,
        metaDescription: "Latest Idaho news, sports, business and entertainment at 6:20 a.m. MDT",
        platformName: "PageBuilder Fusion - Arc Publishing",
        primarySection: {
          _id:  "/wires",
          name:  "Wires",
          path:  "/wires"
        },
        publishedDay: "06",
        publishedMonth: "07",
        publishedYear: "2020",
        stationName: "kmvt",
        timezoneOffset: gdmGoogleTagManager.getTimezoneOffset(),
        userId: null,
        userTimezoneTimestamp: new Date(),
        userTimezone: Intl.DateTimeFormat().resolvedOptions().timeZone,
        userAgent: navigator.userAgent
      }
    ];
  </script><script type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','RCdataLayer','GTM-M5QQ3JP');</script><script type="text/javascript" async="" src="https://widgets.outbrain.com/outbrain.js"></script><script type="text/javascript" src="//cdn.connatix.com/min/connatix.renderer.infeed.min.js" data-connatix-token="f272c3ea-1bb1-4b0e-8c02-e34910608d96" async=""></script>
  <script>(window.BOOMR_mq=window.BOOMR_mq||[]).push(["addVar",{"rua.upush":"false","rua.cpush":"true","rua.upre":"false","rua.cpre":"true","rua.uprl":"false","rua.cprl":"false","rua.cprf":"false","rua.trans":"SJ-15f6cd2c-00bf-4a6e-8220-420a06f517e6","rua.cook":"false","rua.ims":"false","rua.ufprl":"false","rua.cfprl":"false"}]);</script>
  <script>!function(a){var e="https://s.go-mpulse.net/boomerang/",t="addEventListener";if("False"=="True")a.BOOMR_config=a.BOOMR_config||{},a.BOOMR_config.PageParams=a.BOOMR_config.PageParams||{},a.BOOMR_config.PageParams.pci=!0,e="https://s2.go-mpulse.net/boomerang/";if(window.BOOMR_API_key="GLQJ2-RSS42-RZ9SV-M8H2K-AVCDP",function(){function n(e){a.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(!a.BOOMR||!a.BOOMR.version&&!a.BOOMR.snippetExecuted){a.BOOMR=a.BOOMR||{},a.BOOMR.snippetExecuted=!0;var i,o,_,r=document.createElement("iframe");if(a[t])a[t]("load",n,!1);else if(a.attachEvent)a.attachEvent("onload",n);r.src="javascript:void(0)",r.title="",r.role="presentation",(r.frameElement||r).style.cssText="width:0;height:0;border:0;display:none;",_=document.getElementsByTagName("script")[0],_.parentNode.insertBefore(r,_);try{o=r.contentWindow.document}catch(O){i=document.domain,r.src="javascript:var d=document.open();d.domain='"+i+"';void(0);",o=r.contentWindow.document}o.open()._l=function(){var a=this.createElement("script");if(i)this.domain=i;a.id="boomr-if-as",a.src=e+"GLQJ2-RSS42-RZ9SV-M8H2K-AVCDP",BOOMR_lstart=(new Date).getTime(),this.body.appendChild(a)},o.write("<bo"+'dy onload="document._l();">'),o.close()}}(),"".length>0)if(a&&"performance"in a&&a.performance&&"function"==typeof a.performance.setResourceTimingBufferSize)a.performance.setResourceTimingBufferSize();!function(){if(BOOMR=a.BOOMR||{},BOOMR.plugins=BOOMR.plugins||{},!BOOMR.plugins.AK){var e="true"=="true"?1:0,t="",n="nml5ubdaayvogxydgcea-f-51dcfcc98-clientnsv4-s.akamaihd.net",i={"ak.v":"27","ak.cp":"913321","ak.ai":parseInt("584700",10),"ak.ol":"0","ak.cr":1,"ak.ipv":4,"ak.proto":"","ak.rid":"51fd1dc","ak.r":38266,"ak.a2":e,"ak.m":"","ak.n":"essl","ak.bpcip":"107.23.218.0","ak.cport":50782,"ak.gh":"96.6.42.223","ak.quicv":"","ak.tlsv":"tls1.2","ak.0rtt":"","ak.csrc":"-","ak.acc":"reno","ak.t":"1594044552","ak.ak":"hOBiQwZUYzCg5VSAfCLimQ==io4oHhZUA2cOMbBzzq0ATnR1xuVcTIYcTojHbQ/SDAZke19em+Y3o081iJQFe61wzmTMX6nrobaxEVa17fBi1AKGiQse1/ldBl5ZC2HdlF/2QWv1+k0YSZpkgYqk8oxzXlR2ssw+E63FkHJ2TzEY4epGAh+1uaQP8+m2m13BmVm43Yby4GlCSsw1pBc47gcUbzZNrPWD2eTe+31Wdod5wWMdBKR1AJJmdXPPiUA74tjiUXwsTl/9C7pScTMJ3NXn1LFs7w0qmZjSquAEWaWLyftevzlCulcTeZD1sb/+xcc0m0QMGYrSyYFvt0AdsMSW01OEO2ACmLFkDDsF/0RbASLOtbgaq21NyEuK12TM4wHbq+NRpM2wtaocHiOWGvSEBqTb+i3L5GSg319Tf1LsUbJzwuv4MqyzkOF+2DPwTvA=","ak.pv":"4"};if(""!==t)i["ak.ruds"]=t;var o={i:!1,av:function(e){var t="http.initiator";if(e&&(!e[t]||"spa_hard"===e[t]))i["ak.feo"]=void 0!==a.aFeoApplied?1:0,BOOMR.addVar(i)},rv:function(){var a=["ak.bpcip","ak.cport","ak.cr","ak.csrc","ak.gh","ak.ipv","ak.m","ak.n","ak.ol","ak.proto","ak.quicv","ak.tlsv","ak.0rtt","ak.r","ak.acc","ak.t"];BOOMR.removeVar(a)}};BOOMR.plugins.AK={akVars:i,akDNSPreFetchDomain:n,init:function(){if(!o.i){var a=BOOMR.subscribe;a("before_beacon",o.av,null,null),a("onbeacon",o.rv,null,null),o.i=!0}return this},is_complete:function(){return!0}}}}()}(window);</script></head><body><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M5QQ3JP" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fusion-app" class="fusion-app"><div id="article-right-rail-layout" class="includes-right-rail"><header class="masthead | w-100"><div class="masthead | bg-primary-branding py-2" style="background-image:url(&#x27;/pf/resources/images/mastheads/backgrounds/kmvt.jpg?d=73&#x27;)"><div class="container-xl"><div class="d-flex justify-content-between w-100"><div class="logo flex-fill position-relative"><a class="logo-link" href="/"><div class="logo-inner position-absolute" style="background-image:url(&#x27;/pf/resources/images/mastheads/logos/kmvt.svg?d=73&#x27;)"></div></a></div></div></div></div></header><nav class="navigation | w-100"><div class="navigation | navigation-sticky-wrapper" style="min-height:undefinedpx"><div class="navbar | navbar-expand bg-primary-branding"><div class="container-xl position-relative"><a class="navbar-brand mr-1 d-none" href="/"><div class="brand-logo" style="background-image:url(&quot;/pf/resources/images/logo-icons/kmvt.svg?d=73&quot;)"></div></a><button class="side-drawer-toggle btn text-white" type="button"><span class="fas fa-bars"></span></button><ul class="navbar-links | navbar-nav mr-auto font-weight-bold"><li class="navbar-link | navbar-item d-sm-flex d-md-flex d-lg-flex"><a class="nav-link text-white" href="/news">News</a></li><li class="navbar-link | navbar-item d-sm-flex d-md-flex d-lg-flex"><a class="nav-link text-white" href="/weather">Weather</a></li><li class="navbar-link | navbar-item d-none d-sm-flex d-md-flex d-lg-flex"><a class="nav-link text-white" href="/sports">Sports</a></li><li class="navbar-link | navbar-item d-none d-md-flex d-lg-flex"><a class="nav-link text-white" href="/livestream/">LIVE</a></li><li class="navbar-link | navbar-item d-none d-md-flex d-lg-flex"><a class="nav-link text-white" href="/community/user-content">Submit Photos and Videos</a></li></ul><form class="search-box d-flex flex-row rounded position-absolute zindex-high w-auto p-1" action="/search/" method="GET"><input type="checkbox" class="d-none" name="search-action" id="search-action"/><input type="text" class="form-control form-control-sm bg-primary-branding m-0 p-0 border-0" id="expandable-search" name="searchTerm" placeholder="Search..."/><button for="search-action" class="btn border-0 text-white" type="button"><i class="d-block fas fa-search"></i></button></form></div></div></div><div class="side-drawer-screen | fixed-top h-100 w-100 zindex-high"></div><div class="side-drawer | bg-primary-branding shadow-lg fixed-top h-100 w-100 overflow-y overflow-hide-scrollbar"><div class="side-drawer-container | d-none flex-column align-items-end h-100"><div class="side-drawer-cancel | d-flex flex-column align-items-end w-100 p-2"><button class="btn btn-sm text-white"><i class="fas fa-times"></i></button></div><ul class="sections-list | list-unstyled w-100 pt-5 pb-4"><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/homepage">Homepage</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/news">News</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/ap">AP</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/crime">Crime</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/economy">Economy</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/education">Education</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/international">International</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/investigation">Investigation</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/national">National</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/regional">Regional</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/state">State</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/livestream/">LIVE</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/weather">Weather</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/fish-game-forecast">Fish &amp; Game Forecast</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/weather/closings">Closings</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/weather/cams">Weather Cams</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/sports">Sports</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/fish-game-forecast">Fish &amp; Game Forecast</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/sports/scoreboard">Scoreboard</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/community/calendar">Community Calendar</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/page/contact-us">Contact Us</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/page/submit-a-news-story">Submit A News Story</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/community/user-content">Submit Photos and Videos</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/community/obits">Obituaries</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/obituaries">Submit an Obituary</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/politics/election-results">Election Results</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/page/covid-19-map">Covid 19 Map</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/programming/schedule">Programming Schedule</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="https://www.circleplus.com/">Circle - Country Music &amp; Lifestyle</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="https://www.fullcourtgreta.com/">Full Court Press with Greta Van Susteren</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/mr-food">Mr. Food</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.graytvlocal.com/market/southern-idaho">Shop Local</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/contests">Contests</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/links">Special Features</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/education/better-together">Surviving or Thriving</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/interviews">Studio Interviews</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/community/salute-to-farmers">Salute to Farmers</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/pets/furry-friday">Furry Friday</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/health/fit-and-well-idaho">Fit And Well Idaho</a></div></li></ul></div></li></ul><div class="social-bar | d-flex flex-row justify-content-center w-100 mt-auto p-3" style="bottom:0"><a alt="VISIT KMVTNEWS11 ON FACEBOOK" class="p-2" href="https://www.facebook.com/KMVTNews11" rel="noopener noreferrer" target="_blank"><i class="fab fa-facebook-f fa-2x"></i></a><a alt="VISIT KMVTNEWS ON INSTAGRAM" class="p-2" href="https://www.instagram.com/kmvtnews" rel="noopener noreferrer" target="_blank"><i class="fab fa-instagram fa-2x"></i></a><a alt="VISIT KMVTNEWS ON TWITTER" class="p-2" href="https://www.twitter.com/kmvtnews" rel="noopener noreferrer" target="_blank"><i class="fab fa-twitter fa-2x"></i></a><a alt="VISIT KMVT11CBS ON YOUTUBE" class="p-2" href="https://www.youtube.com/user/KMVT11CBS" rel="noopener noreferrer" target="_blank"><i class="fab fa-youtube fa-2x"></i></a></div></div></div></nav><section class="leaderboard | w-100"><div class="arc-ad | text-center ad-flex-leaderboard py-2 d-flex flex-column mt-3 mb-3 justify-content-center ad-type-flex-leaderboard"><div class="arc-ad-wrapper | d-flex flex-column"><div class="text-muted text-uppercase mx-3 small">Advertisement</div><div id="ad-6S7_d_KWhTiP2" class="kmvt/web/wires arcad"></div></div></div></section><div class="container-xl"><div class="row"><section class="top-wrapped | col-12"></section><div class="col-12 d-flex flex-column flex-lg-row w-100"><div class="article-content-container | flex-lg-fill mr-lg-3"><section class="header | w-100"><div class="article-header article row mb-3"><div class="headlines |"><h1 class="headline | font-weight-bold col"><span>Latest Idaho news, sports, business and entertainment at 6:20 a.m. MDT</span></h1><h5 class="subheadline | font-weight-light col"><span>Latest Idaho news, sports, business and entertainment at 6:20 a.m. MDT</span></h5></div><div class="date-time | col-12"><span class="date-time published-date-time font-italic d-inline-block">Published: Jul. 6, 2020 at 3:23 AM MDT</span><span class="px-2 d-inline">|</span><span class="date-time updated-date-time font-italic d-inline-block">Updated: 4 hours ago</span></div><div class="sharebar |  col-12"><div class="btn p-0 facebook"><svg class="icon |  facebook pointer" width="24" height="24" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>Share on Facebook</title><path d="M12 2C6.477 2 2 6.477 2 12c0 4.991 3.657 9.128 8.438 9.878v-6.987h-2.54V12h2.54V9.797c0-2.506 1.492-3.89 3.777-3.89 1.094 0 2.238.195 2.238.195v2.46h-1.26c-1.243 0-1.63.771-1.63 1.562V12h2.773l-.443 2.89h-2.33v6.988C18.343 21.128 22 16.991 22 12c0-5.523-4.477-10-10-10" fill-rule="evenodd"></path></svg></div><div class="btn p-0 mail"><svg class="icon | mail pointer" width="24" height="24" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>Email this link</title><path d="M3.313 5.273C3.493 5.103 3.734 5 4 5h16c.13 0 .253.025.366.07L11.79 12.49 3.313 5.273zM21 7.166V18a1 1 0 0 1-1 1H4a1 1 0 0 1-1-1V7.775l8.064 6.867c.376.32.945.305 1.338-.036L21 7.166z" fill-rule="nonzero"></path></svg></div><div class="btn p-0 twitter"><svg class="icon | twitter pointer" width="24" height="24" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>Share on Twitter</title><path d="M8.29 20.251c7.547 0 11.675-6.253 11.675-11.675 0-.178 0-.355-.012-.53A8.35 8.35 0 0 0 22 5.92a8.189 8.189 0 0 1-2.357.646 4.117 4.117 0 0 0 1.804-2.27 8.222 8.222 0 0 1-2.605.996 4.107 4.107 0 0 0-6.993 3.743 11.65 11.65 0 0 1-8.457-4.287 4.106 4.106 0 0 0 1.27 5.477A4.073 4.073 0 0 1 2.8 9.713v.052a4.105 4.105 0 0 0 3.292 4.022 4.095 4.095 0 0 1-1.853.07 4.108 4.108 0 0 0 3.834 2.85A8.233 8.233 0 0 1 2 18.407a11.617 11.617 0 0 0 6.29 1.84" fill-rule="evenodd"></path></svg></div><div class="btn p-0 pinterest"><svg class="icon | pinterest pointer" width="24" height="24" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>Share on Pinterest</title><path d="M12 2C6.477 2 2 6.477 2 12c0 4.239 2.634 7.86 6.354 9.317-.09-.79-.165-2.008.033-2.873.18-.781 1.169-4.97 1.169-4.97s-.297-.602-.297-1.482c0-1.391.807-2.428 1.811-2.428.856 0 1.267.642 1.267 1.407 0 .856-.543 2.14-.83 3.334-.24.995.501 1.81 1.48 1.81 1.778 0 3.145-1.876 3.145-4.576 0-2.395-1.72-4.066-4.181-4.066-2.848 0-4.519 2.132-4.519 4.338 0 .856.33 1.777.74 2.28.083.098.091.189.067.288-.074.312-.247.995-.28 1.135-.041.181-.148.223-.338.132-1.25-.584-2.033-2.403-2.033-3.876 0-3.153 2.289-6.05 6.61-6.05 3.465 0 6.164 2.47 6.164 5.778 0 3.449-2.173 6.222-5.185 6.222-1.012 0-1.967-.527-2.288-1.152l-.626 2.379c-.222.872-.83 1.958-1.242 2.625.938.288 1.926.444 2.963.444 5.522 0 10-4.477 10-10A9.98 9.98 0 0 0 12 2" fill-rule="evenodd"></path></svg></div><div class="btn p-0 linkedin"><svg class="icon | linkedin pointer" width="24" height="24" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>Share on LinkedIn</title><path d="M4.329 3H19.67C20.405 3 21 3.595 21 4.329V19.67c0 .734-.595 1.329-1.329 1.329H4.33A1.329 1.329 0 0 1 3 19.67V4.329C3 3.595 3.595 3 4.329 3zM18.35 17.901v-5.316c0-2.626-1.632-3.522-3.142-3.522-1.396 0-2.31.904-2.572 1.433h-.035V9.305H10V17.9h2.706v-4.66c0-1.243.787-1.847 1.59-1.847.76 0 1.349.427 1.349 1.812v4.695h2.706zM7.56 8.107c.86 0 1.56-.656 1.56-1.553C9.12 5.656 8.42 5 7.56 5 6.697 5 6 5.656 6 6.554c0 .897.698 1.553 1.56 1.553zm-1.354 9.788h2.706V9.298H6.207v8.597z" fill-rule="evenodd"></path></svg></div></div></div></section><section class="body | w-100"><div class="article-body | article row"><div class="col"><p class="text | article-text">IDAHO PLANE CRASH</p><p class="text | article-text">Sheriff: At least 2 killed in plane collision at Idaho lake</p><p class="text | article-text">COEUR D'ALENE, Idaho (AP) — Authorities in Idaho say two bodies have been recovered and as many as six other people are missing after two small planes collided over Lake Coeur d’Alene. A Kootenai County Sheriff’s statement says witnesses described seeing the planes collide and then crash into the lake near Powderhorn Bay. Lt. Ryan Higgins says two bodies had been recovered, and they don't believe there are any survivors. The victims have not been identified. Investigators are checking initial reports that there were a total of eight passengers and crew on the two planes.</p><p class="text | article-text">ELK POACHING-SENTENCE</p><div></div><p class="text | article-text">6 men sentenced for poaching 19 animals in east Idaho</p><p class="text | article-text">PRESTON, Idaho (AP) — Authorities say six men in eastern Idaho have pleaded guilty to poaching 16 elk and three mule deer. KBOI-TV reported that Jay Reeder, Brandon Porter, Rick Earl, Jesse Earl, Dustin Hollingsworth and Brian Miller reached plea agreements for killing the 19 animals near Preston in the fall of 2018, including several trophy class animals. The Idaho Department of Fish and Game launched an investigation after multiple animals were poached over several months without regard for season, weapon restrictions and tagging requirements. Officials say members of the group also unlawfully killed pheasants, magpies, and wild turkeys baited onto the property.</p><p class="text | article-text">ROCK SLIDE-ROAD CLOSED</p><p class="text | article-text">Rock slide closes Highway 95 in Idaho</p><div></div><p class="text | article-text">RIGGINS, Idaho (AP) — Highway 95 is temporarily closed after a large rock slide blocked the road. The closure starts at New Meadows to five miles south of the Riggins area. Idaho State Police says an alternate route from southwest Idaho to Central or North Idaho would be I-84 west connecting to Highway 12 or I-90 east at Tri-Cities. The Idaho County Sheriff’s Office does not have an estimated time as to when it will be cleaned up. The Forest Service advises French Creek Road is not a recommended, nor an official detour for Highway 95.</p><p class="text | article-text">AMAZON HOMELESS SHELTER-SICK KIDS</p><p class="text | article-text">Amazon homeless shelter boosts unique program for sick kids</p><p class="text | article-text">SEATTLE (AP) — A family homeless shelter has opened inside a gleaming Amazon corporate building on the tech giant’s Seattle campus. It's believed to be the first homeless shelter built inside a corporate building in the U.S. Part of the shelter helps homeless children with life-threatening health conditions. The glass-encased building is divided in half, with the nonprofit on one end and workers in Amazon's cloud computing unit on the other. Two floors are reserved for families dealing with debilitating health issues, many of them with compromised immune systems from chronic illnesses or chemotherapy.</p><div></div><p class="text | article-text">FATHER FINDS MISSING CHILD</p><p class="text | article-text">Child safe after separated from family in Utah mountains</p><p class="text | article-text">SALT LAKE CITY (AP) — An Idaho father has been reunited with his 9-year-old son who went missing during a hike with extended family in Utah. KSL-TV reported that Summit County Sheriff Justin Martinez says the dad drove to Utah where his son, Stratton Joshua Wright, became separated from his uncle, cousins and siblings Wednesday around 8 p.m. during a hike near Bear Lake. Wright was found by his dad in an open field Thursday. He was slightly dehydrated and tired, but otherwise healthy. Helicopters, trained search and rescue crews and horses had also been searching for him.</p><p class="text | article-text">VIRUS OUTBREAK-OREGON-RISING CASES</p><div></div><p class="text | article-text">Oregon thought it had controlled COVID-19, then came surge</p><p class="text | article-text">SALEM, Ore. (AP) — Coronavirus numbers are surging and stretching into small Oregon communities that at the start of June had had few confirmed cases. The Oregon Health Authority said Thursday there were 375 additional confirmed and presumptive cases of the coronavirus statewide. The previous record was 281 cases. Over the past month, the case count more than doubled – surpassing 9,000. While the case count has been increasing across the state, authorities say there have been significant increases in rural counties.  And they worry heading into the holiday weekend about family and friends gathering for parties</p></div></div></section><section class="recommendations | w-100"><div class="connatix | row mb-3"><div class="my-3 col"><div id="connatix-highlights-embed" class="w-100 h-100"></div></div></div><div style="display:none" id="0ffvPqqxRrf" data-fusion-collection="features" data-fusion-type="Ads/OutbrainFeed" data-fusion-message="Could not render component [features:Ads/OutbrainFeed]"></div></section></div><section class="right-rail | rail ml-lg-3 d-flex flex-column flex-lg-fill"><div></div><div class="flex-feature-feed | mb-0"><div class="title-bar | w-100"><h4 class="title | font-weight-bold"><span class="">Latest News</span></h4></div><div class="card-deck mx-n2 mb-0"></div></div><div></div><div class="flex-feature-feed | mb-0"><div class="title-bar | w-100"><h4 class="title | font-weight-bold"><span class="">Latest News</span></h4></div><div class="card-deck mx-n2 mb-0"></div></div><div></div></section></div><section class="bottom-wrapped | col-12"><div></div></section></div></div><footer class="footer | w-100"><div class="arc-ad | text-center ad-flex-leaderboard ad-flex-footer-leaderboard ad-fixed-bottom position-fixed zindex-higher w-100 py-0 my-0 d-flex flex-column justify-content-center ad-type-flex-leaderboard"><div class="arc-ad-wrapper | d-flex flex-column"><div class="ad-dismiss | text-white pointer position-absolute top absolute-right p-1"><i class="far fa-times-circle fa-sm"></i></div><div id="ad-K5yg0dFGWxvCt" class="kmvt/web/wires arcad"></div></div></div><div id="fusion-static-enter:0fdJWhyyNo2r1M1" style="display:none"></div><div class="footer | card bg-primary-branding mt-3 d-flex rounded-0 text-center text-sm-left zindex-highest"><div class="card-body"><div class="container"><div class="row"><div class="col"><div class="footer-links | row justify-content-start my-3"><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/weather" rel="" target="_self">Weather</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/community/calendar" rel="" target="_self">Community Calendar</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/sports" rel="" target="_self">Sports</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/sports/scoreboard" rel="" target="_self">Scoreboard</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/news" rel="" target="_self">News</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/page/contact-us" rel="" target="_self">Contact Us</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/page/obituaries" rel="" target="_self">Submit an Obituary</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/weather/closings" rel="" target="_self">Closings</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/page/advertise-with-us" rel="" target="_self">Advertise With Us</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/weather/cams" rel="" target="_self">Weather Cams</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="https://www.graytvlocal.com/market/southern-idaho" rel="" target="_self">Shop Local</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/page/contact-us" rel="" target="_self">Contact Us</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="https://gray.tv/careers#currentopenings" rel="" target="_self">KMVT Careers</a></div></div></div><div class="col-12 col-sm-5 col-md-3 col-xl-2"><div class="footer-contacts | row justify-content-start my-3 small"><div class="col"><ul class="list-unstyled mb-0"><li class="footer-contact | font-weight-bold">KMVT</li><li class="footer-contact | footer-address">1100 Blue Lakes Blvd. N.</li><li class="footer-contact | footer-city-state">Twin Falls, ID 83301</li><li class="footer-contact | footer-phone">(208) 733-1100</li></ul></div></div></div></div></div></div><div class="card-footer small pt-0"><div class="footer-links | d-flex flex-wrap justify-content-center text-center"><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="https://publicfiles.fcc.gov/tv-profile/kmvt" rel="noopener norefferer" target="_blank">Public Inspection File</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="mailto:publicfile@kmvt.com" rel="noopener norefferer" target="_blank">publicfile@kmvt.com - (208) 733-1100</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/terms-of-service/" rel="noopener norefferer" target="_blank">Terms of Service</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/privacy-policy/" rel="noopener norefferer" target="_blank">Privacy Policy</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="http://media.graytvinc.com/documents/KMVTGray20172018EEOPublicFileReports.pdf" rel="noopener norefferer" target="_blank">EEO Statement</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/advertising/" rel="noopener norefferer" target="_blank">Advertising</a></div></div></div><div class="footer-copyright | card-footer"><div class="font-weight-light small mx-auto text-center">Copyright © 2002-2020 Gray Television, Inc.</div></div></div><div id="fusion-static-exit:0fdJWhyyNo2r1M1" style="display:none"></div></footer></div></div><script type="application/javascript">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</script></body></html>